Jump to content


Photo

Enhanced Log Monitor Linux


  • Please log in to reply
6 replies to this topic

#1 JohnUptime

JohnUptime

    Member

  • Members
  • Pip
  • 8 posts

Posted 12 July 2011 - 03:20 PM

Anybody got the "Enhanced Log Monitor" to work on Linux?

Here is one example of the settings I've tried

Port: 9998
Password: *******
Log Directory: /var/log/
Log Files to Search (regex): auth\.log
Search String (regex): Accepted password

But no matter what settings I use, I always get the same message when I test the service monitor:

Status: WARN
Message: Process returned with warning status - Error: No lines returned from agent.
Error:: No lines returned from agent.
Response time: 1000 ms


#2 Chris Kasza

Chris Kasza

    Champion

  • Uptime Software
  • PipPipPipPipPip
  • 326 posts
  • Gender:Male
  • Location:Canada

Posted 12 July 2011 - 04:03 PM

Hi John,

This suggests that something on the agent side is not configured properly. Have you gone through all the necessary steps to set up the agent side script (installed it in the correct directory with adequate permissions and added an entry to .uptmpasswd)?

- Chris

#3 JohnUptime

JohnUptime

    Member

  • Members
  • Pip
  • 8 posts

Posted 24 August 2011 - 07:22 PM

I've haven't had any luck with this I'm afraid


I can run the perl script on the agent manually by using something like this as an parameter:

/var/logUPDOTTIMEauthUPDOTTIMEsessionUPSPCTIMEopenedUPDOTTIMEUPDOTTIMEOn

That works fine so I guess the perl script is OK


If I deliberately use an incorrect password when I configure the service on the server I get a different error:

Error: Output received: 'ERR'. The agent may not be configured correctly. Check the password?

So I guess the .uptmpasswd file can be read OK?


I thought I might be able to telnet to the agent on port 9998 and send this command:

rexec password /opt/uptime-agent/scripts/log_monitor.pl /var/logUPDOTTIMEauthUPDOTTIMEsessionUPSPCTIMEopenedUPDOTTIMEUPDOTTIMEOn

But that didn't work - the agent just disconnected


I set the agent to run as root (and set all the file permissions appropriately) but that had no effect


I don't know what else to check




#4 Chris Kasza

Chris Kasza

    Champion

  • Uptime Software
  • PipPipPipPipPip
  • 326 posts
  • Gender:Male
  • Location:Canada

Posted 24 August 2011 - 07:37 PM

Hi John,

Are you using the latest scripts available in the Grid?

Chris

#5 Chris Kasza

Chris Kasza

    Champion

  • Uptime Software
  • PipPipPipPipPip
  • 326 posts
  • Gender:Male
  • Location:Canada

Posted 24 August 2011 - 07:37 PM

Sorry, here's the link: http://support.uptim...w.php?mod_id=25

#6 JohnUptime

JohnUptime

    Member

  • Members
  • Pip
  • 8 posts

Posted 05 September 2011 - 03:52 PM

Yes I'm using the latest files on the server and on the agent

#7 Chris Kasza

Chris Kasza

    Champion

  • Uptime Software
  • PipPipPipPipPip
  • 326 posts
  • Gender:Male
  • Location:Canada

Posted 05 September 2011 - 08:33 PM

Hi John,

Could you contact support at support@uptimesoftware.com to schedule a Webex call, so we can have a closer look at the configuration to determine what's missing?

Thanks,
Chris




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users