Jump to content


Photo
- - - - -

Discovered Virtual Machines


  • Please log in to reply
2 replies to this topic

#1 tkrn

tkrn

    Member

  • Members
  • Pip
  • 12 posts

Posted 07 March 2012 - 07:29 PM

Because of security reasons, the hostname/IP name of some of our virtual machines sit behind a 1-1 NAT and the IP address that vCenter reports is the actual IP but everything that needs to communicate to it uses the NAT'ed IP address. Is there a way to override the hostname field on discovered virtual machines in Uptime 6? I see it's greyed out. Will I just need to remove these and then add them manually?

Thanks,

#2 Chris Kasza

Chris Kasza

    Champion

  • Uptime Software
  • PipPipPipPipPip
  • 326 posts
  • Gender:Male
  • Location:Canada

Posted 08 March 2012 - 06:08 PM

A couple other clients have also raised concerns about using the virtual machine hostnames registered in vCenter to monitor the VM's, so the product team is reviewing whether this will be changed in a future release or not.

In the meantime, a possible workaround for you would be to add the hostname/NAT IP address pairings to the host file on the up.time Monitoring Station. That way, up.time will use the NAT IP address rather than the blocked hostname.

#3 David Leith

David Leith

    Guru

  • Uptime Software
  • PipPipPipPip
  • 168 posts
  • Location:Toronto, Ontario

Posted 14 March 2012 - 01:02 PM

Hi,
As Chris mentioned a number of users have asked to have more flexibility in hostname settings for vCenter attached VMs. We're actively working with these users to design a better way to handle this in more complicated network environments. Unfortunately for the near term you're best bet is the hosts file Chris mentioned or adding the VMs and ESX hosts manually without adding your vCenter.

Cheers,

Dave
David Leith
Technical Product Manager

uptime software ...because downtime is not an option




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users